How to upgrade to kernel 3.19 LTS Vivid kernel and xorg graphics for Ubuntu 14.04


Long-term Support for Ubuntu 14.04 also means that you can get the latest stable kernel and graphics as well.  Importantly, these remain supported by the kernel and graphics teams and you’ll receive a regular supply of updates for 9 months.

This article covers the following:

  • background with previously installing the utopic HWE
  • installing the vivid HWE with modified wiki instructions
  • fixing bcmwl wireless issues
  • cleaning up remaining utopic HWE obsolete packages

Background:

I did this previously to get the utopic hardware-enablement stack (HWE), so I was interested to tinker with the very latest supported HWE.

Remember – you’ll need to update just before 9 months to get the next LTS kernel and graphics before support is officially withdrawn.  If this sounds like too much hassle – best stick with the 3.13 kernel and graphics – they remain supported for 5 years!


Installing the vivid HWE:

The community wiki page describes how to install the latest kernel and graphics – but you need to be very careful.

The wiki page stated that to upgrade the kernel and graphics you use the following (sub utopic with vivid):

sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid

Remember the magic “-s” parameter; with “-s” added you can simulate what would happen when you run an install command – for me, it revealed that there was a nasty conflict message.


sudo apt-get install -s --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies.
libgl1-mesa-glx-lts-vivid : Depends: libglapi-mesa-lts-vivid (= 10.5.2-0ubuntu1~trusty1) but it is not going to be installed
xserver-xorg-lts-vivid : Recommends: libegl1-mesa-drivers-lts-vivid but it is not installable
Recommends: libgles2-mesa-lts-vivid but it is not going to be installed
Recommends: libgles1-mesa-lts-vivid but it is not going to be installed
Conflicts: libglapi-mesa (>= 0~)
Conflicts: libgles2-mesa (>= 0~)
E: Unable to correct problems, you have held broken packages.

I fixed this with adding libglapi-mesa-lts-vivid.

sudo apt-get -s install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libglapi-mesa-lts-vivid | more

N.B. press q to exit the paused display

I checked very closely the packages to be removed. I was happy to see all the utopic xserver packages being removed… however I noticed amongst the packages it would have removed were vital wine packages.

Instead I preserved my wine installation through this simulated command:

sudo apt-get -s install --install-recommends linux-generic-lts-vivid xserver-xorg-lts-vivid libgl1-mesa-glx-lts-vivid libglapi-mesa-lts-vivid libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid:i386 | more

Try the above and examine which packages would be removed.

Once you are happy – go ahead and remove the “-s” after the apt-get.


Fixing bcmwl wireless issues:

I mentioned in my previous article that upgrading to the utopic HWE my bcmwl wireless could have been left in a broken state because the bcmwl package had not yet been backported; since that report there has been no movement with this bug so I can assume bcmwl wireless would remain broken for anyone upgrading to vivid HWE from stock 14.04.2 kernel and graphics.

Indeed – after installing the vivid HWE above I saw the following:


Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.19.0-23-generic /boot/vmlinuz-3.19.0-23-generic
run-parts: executing /etc/kernel/postinst.d/dkms 3.19.0-23-generic /boot/vmlinuz-3.19.0-23-generic
Error! Could not locate dkms.conf file.
File: does not exist.
Error! Bad return status for module build on kernel: 3.19.0-23-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.248+bdcom/build/make.log for more information.

So BEFORE I rebooted, I downloaded the wily (15.10) bcmwl package ready to install after rebooting.

wget http://mirrors.kernel.org/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu2_amd64.deb

If you are still using 32bit then the equivalent package for you is:

http://mirrors.kernel.org/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu2_i386.deb

After rebooting I installed the new wily deb with:

sudo dpkg -i bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu2_amd64.deb

Wireless sprang back into life and all is well.


 

Cleaning up:

Since I previously installed the utopic HWE I’m no longer interested in receiving future kernel updates for this LTS kernel. Thus, to do this remove the utopic kernel metapackage:

sudo apt-get purge linux-generic-lts-utopic

If necessary also remove the following packages:

sudo apt-get purge linux-lts-utopic-tools*

Then remove any obsolete packages

sudo apt-get autoremove
Advertisements

7 thoughts on “How to upgrade to kernel 3.19 LTS Vivid kernel and xorg graphics for Ubuntu 14.04

  1. OMG, such a clean way to get a higher MESA. Thank you! Worked like a charm! I hope it won’t crash further down the road, but it restarted perfectly and Mesa went from 10.1.3 to 10.5.9
    Thanks!

    • ok, this worked, but then it crashes if I want to use the nvidia drivers. I think it’s because the drivers are compiled and setup for 14.04 (nvidia-346).

      I think I’ll try to reverse it :-<

  2. Hi I ran you command for the kernel and mesa updates but still getting errors

    The following packages have unmet dependencies:
    xserver-xorg-lts-vivid : Recommends: libegl1-mesa-lts-vivid but it is not going to be installed
    Recommends: libegl1-mesa-drivers-lts-vivid but it is not installable
    Conflicts: libegl1-mesa (>= 0~)
    Conflicts: libwayland-egl1-mesa (>= 0~)
    E: Unable to correct problems, you have held broken packages

    • Given that you are using Freya there maybe extra graphics library requires over and beyond stock ‘buntu.

      Suggest append the following packages to the install line

      – libegl1-mesa-lts-vivid libwayland-egl1-mesa-lts-vivid

  3. Nice. It should be noted that if anything breaks you should still be able to boot to the old kernel from the startup screen, and all should work as before.

    What is the graphics update you did? I assume that’s just baked into the latest kernel?

    • Good point with the old-kernel tip. Fortunately for me I havent had any kernel issues for a long-long time.

      I use Intel graphics which is automatically part of the xserver-xorg packages installed. Similarly – those packages will install the other types of opensource graphics. If you are using proprietary graphics you’ll need find the latest drivers compatible with xorg that comes with vivid i.e. version 1.17

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s